30 lines
734 B
Bash
30 lines
734 B
Bash
# Maintainer: Decadic
|
|
|
|
pkgname=safe-harbor-git
|
|
pkgver=r1.000000
|
|
pkgrel=1
|
|
pkgdesc=""
|
|
arch=("any")
|
|
url="https://git.decade.cz/decadic/safe-harbor"
|
|
license=("GPL-3")
|
|
depends=("python")
|
|
source=("$pkgname::git+https://git.decade.cz/decadic/safe-harbor.git")
|
|
sha256sums=("SKIP")
|
|
|
|
pkgver() {
|
|
cd $pkgname
|
|
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname
|
|
|
|
# prepare dirs
|
|
install -dm755 "$pkgdir/usr/lib/safe-harbor"
|
|
install -dm755 "$pkgdir/usr/lib/systemd/system"
|
|
install -dm755 "$pkgdir/etc/safe-harbor"
|
|
|
|
cp lib/safe-harbor.py "$pkgdir/usr/lib/safe-harbor"
|
|
cp systemd/safe-harbor@.service "$pkgdir/usr/lib/systemd/system"
|
|
cp config.json.example "$pkgdir/etc/safe-harbor"
|
|
}
|