- migrated to Exherbo

- added a few initial Pantheon components
This commit is contained in:
Martin Sekera 2018-12-08 23:26:56 +01:00
parent cb6360a7e8
commit 2d2bbbc830
85 changed files with 931 additions and 2 deletions

View file

@ -0,0 +1,14 @@
--- configure.ac.old 2015-12-02 22:23:48.726073674 -0600
+++ configure.ac 2015-12-02 22:22:48.788098649 -0600
@@ -75,9 +75,10 @@
AC_SUBST(PULSE_CFLAGS)
# If using GCC specifiy some additional parameters
+# Modified 2015-12-02 by Philip Creighton <phil@pdc302.net> to include compile flags for c++11
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall -W -Wno-unused-parameter"
- CXXFLAGS="$CXXFLAGS -pipe -Wall -W"
+ CXXFLAGS="$CXXFLAGS -pipe -Wall -W -std=c++11"
fi
ZP_LYNX_DOC

View file

@ -0,0 +1,42 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils
DESCRIPTION="Pulseaudio Volume Control, GTK based mixer for Pulseaudio"
HOMEPAGE="http://freedesktop.org/software/pulseaudio/pavucontrol/"
SRC_URI="http://freedesktop.org/software/pulseaudio/${PN}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="nls"
RDEPEND="
>=dev-cpp/gtkmm-3.0:3.0
>=dev-libs/libsigc++-2.2:2
>=media-libs/libcanberra-0.16[gtk3]
>=media-sound/pulseaudio-3[glib]
virtual/freedesktop-icon-theme
"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? (
dev-util/intltool
sys-devel/gettext
)
"
src_prepare() {
epatch "${FILESDIR}"/pavucontrol-3.0-c11.patch
}
src_configure() {
econf \
--docdir=/usr/share/doc/${PF} \
--htmldir=/usr/share/doc/${PF}/html \
--disable-lynx \
$(use_enable nls)
}